當前位置:首頁>微思動態>詳情
全國熱線電話 400-881-4699

在線留言

【實驗】使用三層交換機實現單臂路由實驗

發布作者:微思網絡   發布時間:2019-06-13   瀏覽量:0

在現實環境中,有時候不一定將網關啟用在路由器上,有時候實現單臂路由功能不一定必須接在路由器上接口上,可以使用三層交換機實現,因為交換機本身具有豐富的接口這樣靈活的使用,在實際工作中很常見。讀者可以對比上一篇文章《單臂路由實驗(子接口的使用)》,從中感悟其中的奧妙。

具體的操作如下:

背景描述:在switch1-2950T-24上需要兩個vlan(vlan 501/406),vlan 501使用前10個端口,vlan406使用0/11-0/20端口,vlan 501使用10.63.201.0/24網段;vlan 406使用10.63.206.0/25網段;網關使用最后一個可用地址;管理地址vlan 1使用10.63.207.128/25.

1、網絡拓撲結構圖

214857105.png

2、在核心交換機(C3560-24PS)上的操作

Switch>en

Switch#conf

Switch#configure

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line.  End with CNTL/Z.


(1)此處沒有命名設備,啟用telnet用戶口令

Switch(config)#line vty

Switch(config)#line vty 0 4

Switch(config-line)#login

% Login disabled on line 66, until 'password' is set

% Login disabled on line 67, until 'password' is set

% Login disabled on line 68, until 'password' is set

% Login disabled on line 69, until 'password' is set

% Login disabled on line 70, until 'password' is set

Switch(config-line)#pas

Switch(config-line)#password 123123

Switch(config-line)#exi


(2)創建vlan

Switch(config)#vlan 501

Switch(config-vlan)#ex

Switch(config)#vlan 406

Switch(config-vlan)#ex


(3)指定接口網關地址

Switch(config)#inter

Switch(config)#interface vla

Switch(config)#interface vlan 501

%LINK-5-CHANGED: Interface Vlan501, changed state to up

Switch(config-if)#ip ad

Switch(config-if)#ip address 10.63.201.254 255.255.255.0

Switch(config-if)#exi

Switch(config)#inter

Switch(config)#interface vlan 406

%LINK-5-CHANGED: Interface Vlan406, changed state to up

Switch(config-if)#ip address 10.63.206.126 255.255.255.128

Switch(config-if)#ex


(4)添加對應vlan的地址池

Switch(config)#ip dhcp pool vlan501

Switch(dhcp-config)#net

Switch(dhcp-config)#network 10.63.201.0 255.255.255.0

Switch(dhcp-config)#default-router 10.63.201.254

Switch(dhcp-config)#dns-server 10.10.2.1

Switch(dhcp-config)#ex

Switch(config)#ip dhcp po

Switch(config)#ip dhcp pool vlan406

Switch(dhcp-config)#network 10.63.206.0 255.255.255.128

Switch(dhcp-config)#default-router 10.63.206.126

Switch(dhcp-config)#dns-server 10.10.2.1

Switch(dhcp-config)#ex

Switch(config)#


(5)啟用trunk模式

Switch(config)#interface f

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#sw

Switch(config-if)#switchport mode trunk

Command rejected: An interface whose trunk encapsulation is "Auto" can not be configured to "trunk" mode.

Switch(config-if)#exi

Switch(config)#ex

%SYS-5-CONFIG_I: Configured from console by console

Switch#write    //   保存一下


3、在匯聚交換機上的操作

Switch>

Switch>en

Switch#conf

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line.  End with CNTL/Z.

Switch(config)#


(1)添加telnet用戶口令

Switch(config)#line vty

Switch(config)#line vty 0 4

Switch(config-line)#login

% Login disabled on line 66, until 'password' is set

% Login disabled on line 67, until 'password' is set

% Login disabled on line 68, until 'password' is set

% Login disabled on line 69, until 'password' is set

% Login disabled on line 70, until 'password' is set

Switch(config-line)#pas

Switch(config-line)#password 123123

Switch(config-line)#exi


(2)添加vlan

Switch(config)#vlan 501

Switch(config-vlan)#ex

Switch(config)#vlan 406

Switch(config-vlan)#ex


(3)對應的接口啟用trunk模式

Switch(config)#inter

Switch(config)#interface gigabitEthernet 1/1

Switch(config-if)#no shutdown

Switch(config-if)#sw

Switch(config-if)#switchport m

Switch(config-if)#switchport mode trunk


%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/1, changed state to up


Switch(config-if)#ex

Switch(config)#inter

Switch(config)#interface f

Switch(config)#interface fastEthernet 0/1

Switch(config-if)#sw

Switch(config-if)#sw

itchport mode t

Switch(config-if)#switchport mode trunk

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up


Switch(config-if)#no shutdown

Switch(config-if)#ex

Switch(config)#


(4)添加廈門HCNP培訓管理地址

Switch(config)#inter

Switch(config)#interface vlan 1

Switch(config-if)#no shutdown


%LINK-5-CHANGED: Interface Vlan1, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan1, changed state to up


Switch(config-if)#ip address 10.63.207.129 255.255.255.128

Switch(config-if)#ex

Switch(config)#ip default-gateway 10.63.207.254

Switch(config)#ex


%SYS-5-CONFIG_I: Configured from console by console

Switch#


4、在接入交換機上的操作

Switch>en

Switch#conf

Configuring from terminal, memory, or network [terminal]?

Enter configuration commands, one per line.  End with CNTL/Z.


(1)添加telnet用戶口令

Switch(config)#line vty

Switch(config)#line vty 0 4

Switch(config-line)#login

% Login disabled on line 66, until 'password' is set

% Login disabled on line 67, until 'password' is set

% Login disabled on line 68, until 'password' is set

% Login disabled on line 69, until 'password' is set

% Login disabled on line 70, until 'password' is set

Switch(config-line)#pas

Switch(config-line)#password 123123

Switch(config-line)#exi


(2)添加vlan

Switch(config)#vlan 501

Switch(config-vlan)#ex

Switch(config)#vla

Switch(config)#vlan 406

Switch(config-vlan)#ex


(3)啟用trunk模式

Switch(config)#inter

Switch(config)#interface g

Switch(config)#interface gigabitEthernet 1/1

Switch(config-if)#no shutdown

Switch(config-if)#sw

Switch(config-if)#switchport mode trunk

Switch(config-if)#ex


(4)將對應的接口劃入對應vlan

Switch(config)#inter

Switch(config)#interface range f

Switch(config)#interface range fastEthernet 0/1-10

Switch(config-if-range)#no shutdown

Switch(config-if-range)#sw

Switch(config-if-range)#switchport access vlan 501

Switch(config-if-range)#ex

Switch(config)#inter

Switch(config)#interface r

Switch(config)#interface range f

Switch(config)#interface range fastEthernet 0/11-20

Switch(config-if-range)#no shutdown

Switch(config-if-range)#switchport ac

Switch(config-if-range)#switchport access vlan 406

Switch(config-if-range)#ex


(5)添加管理vlan的管理地址

Switch(config)#inter

Switch(config)#interface vlan 1

Switch(config-if)#ip ad

Switch(config-if)#ip address 10.63.207.130 255.255.255.128

Switch(config-if)#exi

Switch(config)#ip default-gateway 10.63.207.254

Switch(config)#ex

Switch#write      //保存一下  

Switch#

5、檢驗一下,看看能否自動獲取ip地址

214906677.png

222239186.png

6、ping一下,試試

222852290.png

返回頂部
南粤风彩26选5开奖